内网渗透 powershell 基础命令

2020年04月05日 13:47:49 作者:必火 阅读数:184275
网络安全渗透测试北京实地培训,五个月华丽蜕变,零元入学,报名联系:18622800700(手机同微信)。全国诚招招生代理,最低2000元起

操作系统
版本
是否升级
windows7/windows server2008
2.0
可升级为3.0/4.0
windows 8 /windows server2012
3.0
可升级4.0
windows8.1/windows server 2012 r2
4.0

1,输入get-host 或者 $PSVersionTable.PSVERSION 获取版本

2,执行策略

powershell 默认无法执行,可以使用cmdlet查询当前的执行策略。

  1. get-executionpolicy  
  2. restricted: 脚本不能运行(默认设置)
  3. remoteSigned: 在本地创建的脚本可以运行,但从网上下载的脚本不能运行(拥有数字证书签名的除外)
  4. AllSigned: 仅当脚本由收信任的发布者签名时才能运行
  5. Unrestricted: 允许所有脚本运行

复制代码

使用 set-executionPolicy <Unrestricted> 设置执行策略。